Groups are not clickable from Groups Page in Atlassian Administration

Incident Report for Jira

Resolved

We have implemented the fix and the group page in the Admin Hub is now functioning as expected.
Posted Feb 18, 2026 - 11:30 UTC

Monitoring

We have identified the root cause, and fix has been rolled out to mitigate the problem. We are monitoring the progress.
Posted Feb 18, 2026 - 11:28 UTC

Investigating

Org Admins are unable to click on any group from Groups page in Atlassian administration (admin.atlassian.com). Admins are unable to adding/removing users and app access from the groups while accessing from admin.atlassian.com.

We are currently investigating the problem. Next update will be shared in 60 mins or sooner.
Posted Feb 18, 2026 - 10:57 UTC
This incident affected: Viewing content, Create and edit, Authentication and User Management, Search, Notifications, Administration, Marketplace, Mobile, Purchasing & Licensing, Signup, and Automation for Jira.