Organization administrators can now receive personalized incident information in Atlassian Administration. Subscribe to System Health (currently in Beta) to receive notifications if a reliability incident affects your organization.
On 20 November 2025, affected Jira users may have experienced some service disruption for Forge custom fields on Jira issue create. The issue has now been resolved, and the service is operating normally for all affected customers.
Posted Nov 20, 2025 - 21:48 UTC
Identified
The incident involves Ecosystem and Jira products, specifically affecting the Forge Jira Custom Fields. Customers may experience a loss of values upon selection on the Issue Create Screen.
The root cause is identified and we are working on deploying a fix.
Posted Nov 20, 2025 - 21:48 UTC
This incident affected: Viewing content, Create and edit, Authentication and User Management, Search, Notifications, Administration, Marketplace, Mobile, Purchasing & Licensing, Signup, and Automation for Jira.