Forge Custom Fields loses value after submission on Issue Create Screen

Incident Report for Jira

Resolved

On 20 November 2025, affected Jira users may have experienced some service disruption for Forge custom fields on Jira issue create. The issue has now been resolved, and the service is operating normally for all affected customers.
Posted Nov 20, 2025 - 22:00 UTC

Identified

We understand that Users are experiencing issues with Forge Custom Fields not retaining selected values on Issue Create Screen.
We have identified the root cause and actively working on deploying a fix.
Issue start time: 2025-11-20T07:00
Posted Nov 20, 2025 - 20:31 UTC
This incident affected: Create and edit.