Users may experience performance degradation when loading the issue view

Incident Report for Jira

Resolved

Between 14:22 UTC to 16:41 UTC, we experienced performance degradation for Jira Service Management and Jira. The issue has been resolved and the service is operating normally.
Posted 15 days ago. Mar 18, 2025 - 16:42 UTC

Investigating

We are investigating cases of degraded performance for some Jira Service Management and Jira Cloud customers. We will provide more details within the next hour.
Posted 15 days ago. Mar 18, 2025 - 16:24 UTC
This incident affected: Viewing content.