Jira Cloud performance degraded across all browsers
Incident Report for Jira Software
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 23:47 UTC
Monitoring
We have identified the possible root cause of the increased error rates and applied a fix. We are now monitoring closely.
Posted Sep 22, 2021 - 18:48 UTC
Investigating
We are investigating cases of degraded performance for multiple Jira Cloud customers. We will provide more details within the next hour.
Posted Sep 22, 2021 - 14:44 UTC