Degraded performance detected in Jira, Jira Work Management and Jira Service Management Issue View experience

Incident Report for Jira

Resolved

A mitigation for the performance issues has been implemented and this incident is now resolved.
Posted 6 days ago. Mar 07, 2025 - 14:44 UTC

Update

We are continuing to investigate this issue.
Posted 6 days ago. Mar 07, 2025 - 10:08 UTC

Investigating

We are aware of some users experiencing extended load times when attempting to view issues in Jira, Jira Work Management and Jira Service Management.
Our team is investigating this issue.
Posted 6 days ago. Mar 07, 2025 - 05:11 UTC
This incident affected: Viewing content, Create and edit, Authentication and User Management, Search, Notifications, Administration, Marketplace, Mobile, Purchasing & Licensing, Signup, and Automation for Jira.