Users experiencing issues loading work items in Atlassian products

Incident Report for Jira

Resolved

The issues relating to viewing and creating work items in Jira should now be fully resolved.
Posted Jun 07, 2026 - 00:13 UTC

Monitoring

A fix has been implemented for the issues some customers have been experiencing with creating and viewing work items in Jira. We are now monitoring for this recovery and will update shortly with further confirmation.
Posted Jun 07, 2026 - 00:07 UTC

Investigating

We are aware of users currently experiencing loading work items across Atlassian products in some regions. We are investigating with urgency and will provide update within one hour.
Posted Jun 06, 2026 - 23:21 UTC
This incident affected: Viewing content and Create and edit.