Allow Access consent loop
Incident Report for Jira Software
Resolved
Between 07/Jul/22 8:00 PM and 19/Jul/22 3:13 AM we experienced an issue where some customers granting access to an app could have entered into a loop where the user was continually asked to grant access. This effectively blocked the user from using the app. This state was triggered for apps that modified egress permissions and did not modify scopes. Forge apps in Confluence, Jira Work Management, and Jira Software were affected. The issue has been resolved and the services are operating normally.
Posted Jul 21, 2022 - 07:16 UTC
Update
We have partially mitigated the issue - the condition in which user is being prompted continuously for consent and unable to use app is now less likely to happen but still possible.

The incident team is investigating this problem further to find root cause of remaining source of reliability problems.
Posted Jul 18, 2022 - 18:39 UTC
Identified
We continue to work on resolving the Forge access grant for Confluence, Jira Work Management and Jira Software. We have identified the issue is caused by caching in the browser or a front end system.

A browser page refresh on the access grant page will allow the access to be granted and it will then not loop.
Posted Jul 18, 2022 - 07:03 UTC
Investigating
We are investigating reports of a consent loop when upgrading scopes on a Forge app. We are currently trying to reproduce the issue. We will provide more details once we identify the root cause.
Posted Jul 18, 2022 - 02:18 UTC
This incident affected: Marketplace.