Delays in Jira webhook delivery

Incident Report for Jira

Identified

We have identified the cause of the delayed Jira webhook delivery and are deploying a fix. We will continue to provide updates as more information becomes available.
Posted Apr 30, 2026 - 10:05 UTC

Investigating

We are investigating reports of delays in webhook delivery. Customers may experience intermittent delays when receiving webhooks. Our engineering teams are actively investigating and working to resolve the issue. We will provide updates as more information becomes available.
Posted Apr 30, 2026 - 08:59 UTC
This incident affects: Notifications.