Automations aren't triggering on work item creation, field updates, or comment additions

Incident Report for Jira

Postmortem

Summary

On March 18, 2026, between 10:06 and 13:47 UTC, customers experienced delays in Automation rules executing when triggered by Jira events such as Work Item creation, Work Item updates, and comments. Automation rules using other trigger types, including scheduled triggers, manual triggers, and incoming webhooks, continued to operate normally.

The incident was caused by an internal configuration change that inadvertently disabled the event delivery pathway used to notify the automation platform of changes in Jira. The incident was identified through customer support tickets and verified through our monitoring; engineering teams were engaged for resolution. Once the root cause was identified, the configuration was corrected and normal automation processing resumed.

Following restoration, the delayed events began flowing to the automation platform for processing. This backlog took approximately 14 hours to fully clear. During this recovery window, some automation rules ran on Work Items whose data had changed due to user actions, customer mitigation, or other causes. Since rule execution usually follows triggering events closely, many customer rules assume immediate execution on the Work Item. The delay allowed other changes —such as updates or customer actions to mitigate the incident's impact — to occur, causing unintended consequences when the rule executed later.

IMPACT

During the impact window, Jira Cloud customers were unable to rely on timely execution of event‑triggered automation rules. Rules that depended on Jira Work Item events - including Work Item created, Work Item updated, comment added, sprint changes, and version changes - ran with significant delays. This affected automated workflows responsible for Work Item routing, notifications, field updates, and other rule‑driven actions throughout the outage. Automation rules that used scheduled, manual, or incoming webhook triggers remained unaffected.

Following mitigation, a recovery period of approximately 14 hours was required to process the backlog of delayed events. During this window, processing delays peaked at approximately 12 hours from event occurrence to rule completion. In some cases, rules executing against Work Item data several hours after the rule trigger occurred, caused problems due to the rules being built with the expectation in mind that little time would pass between trigger and execution. This resulted in Work Items ending up in an unintended state; especially as some customers undertook manual intervention given the situation.

ROOT CAUSE

The incident was caused by a configuration change to an internal feature flag used to control event delivery to the automation platform.

A code change had been prepared to remove a feature flag from the event delivery system. However, this code change had not yet been deployed to production. When the feature flag was subsequently retired through our feature flag management system, the retirement process relied on usage telemetry that incorrectly indicated the flag was no longer active. This inadvertently created a blind spot where the flag appeared unused when it was in fact being actively evaluated.

When the flag was retired, the event delivery system interpreted its absence as an instruction to stop delivering Jira events to the automation platform, causing all event-triggered automation rules to stop firing.

REMEDIAL ACTIONS PLAN & NEXT STEPS

We understand that outages impact your productivity. In addition to our existing testing and preventative processes, Atlassian is prioritising the following actions to help reduce the likelihood and impact of similar incidents in the future:

  • Strengthen feature flag lifecycle safety controls

    • Address the telemetry gap by removing feature flagged code from the hot path of our event processing framework where it was being surpressed, ensuring we have good telemetry on feature flag use across our systems. This will prevent inadvertent archival of feature flags in future.
    • Refine feature flag retirement processes so that flags cannot be retired without verifying actual production usage, independent of standard telemetry signals.
  • Improve event delivery monitoring and alerting

    • Refine monitoring to detect drops in automation event delivery rates within minutes, and add automated alerting on automation execution volume anomalies to enable faster detection of disruptions.
  • Improve our ability to clear delayed events faster and deliver controls for customers to decide alternative workflows for events based on delay.

    • Refine replay infrastructure to recover faster from the pent up backlog that can be created due to delays.
    • Provide workflow components that allow users to decide what to do for varying delays between the triggering event and when the rule gets executed to reduce the risk of unintended changes during recovery.

We recognise the importance of Jira Automation to our customers' workflows and are committed to ongoing improvements to the reliability and resilience of our platform. We sincerely apologize for the disruption this incident caused, and we will continue to invest in measures that support a stable and dependable service.

Thanks,
Atlassian Customer Support

Posted Apr 02, 2026 - 07:09 UTC

Resolved

The vast majority of customers historical events have now all been processed successfully, with a small group of customers that have very high volume of automations still to process which are actively underway.
We expect these remaining processes to be completed within approximately two hours, if not sooner.
Posted Mar 19, 2026 - 04:08 UTC

Update

Processing of the historical events is still occurring with our team monitoring progress closely. We will be providing a further update either when these tasks are fully completed or within 4 hours, whichever is earlier.
Posted Mar 18, 2026 - 23:44 UTC

Update

We have successfully completed the replay for most regions, with remainder expected to finish in next 3 hours.
Posted Mar 18, 2026 - 21:44 UTC

Update

We are replaying historical events for affected customers to rerun Automation rules that failed to execute between March 18, 10:00 AM UTC and 1:45 PM UTC. We are closely monitoring the results of this replay and will post an update in a few hours when this work is complete.
Posted Mar 18, 2026 - 14:53 UTC

Monitoring

We have identified the cause of the issue and deployed changes that have restored automation processing for Jira and Jira Service Management. Automations are now triggering as expected. We will continue to monitor closely to confirm stability.
Posted Mar 18, 2026 - 14:03 UTC

Update

We continue to investigate the issue, and the next communication will be issued in 60 minutes, or sooner if a significant milestone is achieved.
Posted Mar 18, 2026 - 14:01 UTC

Update

We continue to investigate the issue, and the next communication will be issued in 60 minutes, or sooner if a significant milestone is achieved.
Posted Mar 18, 2026 - 13:07 UTC

Update

Customers using Jira and Jira Service Management are currently experiencing an issue where automations do not trigger for actions such as work item creation, field updates, and comment additions, although manual triggers remain functional. We'll share updates here as more information is available.
Posted Mar 18, 2026 - 12:24 UTC

Update

Some customers may experience automations not triggering for specific actions such as work item creation, updates, and comment additions. However, manually triggered automations are operating as expected.
Posted Mar 18, 2026 - 11:32 UTC

Investigating

We are investigating reports of intermittent errors for SOME Jira Cloud customers for Automations triggering. We will provide more details once we identify the root cause.
Posted Mar 18, 2026 - 11:29 UTC
This incident affected: Viewing content, Create and edit, Authentication and User Management, Search, Notifications, Administration, Marketplace, Mobile, Purchasing & Licensing, Signup, and Automation for Jira.