Users experiencing 'file failed to upload' errors when attempting to upload attachments in work items

Incident Report for Jira

Resolved

Our team has now confirmed that attachment uploads are functioning as expected and that this issue is now resolved.
Posted Jun 19, 2025 - 04:06 UTC

Monitoring

Our team has identified the cause of this problem and has put in a fix in place to rectify the issue with attachments not uploading correctly.
We are now monitoring this fix and will provide further update when this issue has been resolved.
Posted Jun 19, 2025 - 03:56 UTC

Investigating

We are aware of some users experiencing a 'The following files have failed to upload' error when attempting to upload attachments to their work items. Our team is investigating this issue with urgency and we will provide an update as soon as available.
Attaching files within a comment appears to remain successful at this time.
Posted Jun 19, 2025 - 03:05 UTC
This incident affected: Viewing content and Create and edit.